Latency due to a global Amazon Web Services (AWS) issue

Incident Report for Contentsquare

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:35 UTC

Identified

You may experience some latency to a global Amazon Web Services (AWS) issue, we are working to resolve this.
Posted Oct 20, 2025 - 11:12 UTC