Access issues: problems accessing projects

Incident Report for Contentsquare

Resolved

This incident has been resolved.
Posted Oct 31, 2025 - 12:46 UTC

Monitoring

A fix has been implemented and we are monitoring.
Posted Oct 31, 2025 - 12:11 UTC

Investigating

We are currently experiencing issues with the platform and access to projects. We are working hard to resolve this and will update here as soon as we have further information.
Posted Oct 31, 2025 - 12:10 UTC